summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlexandros Frantzis <alexandros.frantzis@collabora.com>2017-12-04 15:34:03 +0200
committerPekka Paalanen <pekka.paalanen@collabora.co.uk>2017-12-12 12:17:08 +0200
commit5d6acf8568412a9429018d20382979aedd984140 (patch)
treefa125bac6992827391b680e08294e6636db75afb /Makefile.am
parentfbf165f5e89576730eed4a7e3979100311c4f0f8 (diff)
downloadweston-5d6acf8568412a9429018d20382979aedd984140.tar.gz
weston-5d6acf8568412a9429018d20382979aedd984140.tar.bz2
weston-5d6acf8568412a9429018d20382979aedd984140.zip
tests: Move wl_pointer tests to their own file
Move wl_pointer tests from event-test.c to their own pointer-test.c file. This move makes the test organization clearer and more consistent, and will make addition of further pointer tests easier. Signed-off-by: Alexandros Frantzis <alexandros.frantzis@collabora.com> Reviewed-by: Pekka Paalanen <pekka.paalanen@collabora.co.uk>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index a7ec60b7..7adc6254 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1226,7 +1226,7 @@ weston_tests = \
bad_buffer.weston \
keyboard.weston \
event.weston \
- button.weston \
+ pointer.weston \
text.weston \
presentation.weston \
viewporter.weston \
@@ -1383,9 +1383,9 @@ event_weston_SOURCES = tests/event-test.c
event_weston_CFLAGS = $(AM_CFLAGS) $(TEST_CLIENT_CFLAGS)
event_weston_LDADD = libtest-client.la
-button_weston_SOURCES = tests/button-test.c
-button_weston_CFLAGS = $(AM_CFLAGS) $(TEST_CLIENT_CFLAGS)
-button_weston_LDADD = libtest-client.la
+pointer_weston_SOURCES = tests/pointer-test.c
+pointer_weston_CFLAGS = $(AM_CFLAGS) $(TEST_CLIENT_CFLAGS)
+pointer_weston_LDADD = libtest-client.la
devices_weston_SOURCES = tests/devices-test.c
devices_weston_CFLAGS = $(AM_CFLAGS) $(TEST_CLIENT_CFLAGS)