summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorEmmanuel Gil Peyrot <emmanuel.peyrot@collabora.com>2017-10-03 14:36:21 +0100
committerDaniel Stone <daniels@collabora.com>2017-12-01 17:04:30 +0000
commit55cdf69b4b70f9d954d71187a9dd85f26633befe (patch)
treeffbc4b630f4e9b786252eb97d7197dcf32c80956 /Makefile.am
parent7092090de9f0f619272e52f65decdce86bc532f9 (diff)
downloadweston-55cdf69b4b70f9d954d71187a9dd85f26633befe.tar.gz
weston-55cdf69b4b70f9d954d71187a9dd85f26633befe.tar.bz2
weston-55cdf69b4b70f9d954d71187a9dd85f26633befe.zip
weston-info: Add support for zwp_linux_dmabuf_v1
This now prints each (format, modifier) tuple, to show which ones the compositor sends to its clients. It is only implemented for version 3+, since I didn’t have any compositor implementing previous versions, and the old `format` event is deprecated anyway. Signed-off-by: Emmanuel Gil Peyrot <emmanuel.peyrot@collabora.com> Reviewed-by: Daniel Stone <daniels@collabora.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 9d99c694..e7e6a0ed 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -835,7 +835,9 @@ weston_info_SOURCES = \
shared/helpers.h
nodist_weston_info_SOURCES = \
protocol/presentation-time-protocol.c \
- protocol/presentation-time-client-protocol.h
+ protocol/presentation-time-client-protocol.h \
+ protocol/linux-dmabuf-unstable-v1-protocol.c \
+ protocol/linux-dmabuf-unstable-v1-client-protocol.h
weston_info_LDADD = $(WESTON_INFO_LIBS) libshared.la
weston_info_CFLAGS = $(AM_CFLAGS) $(CLIENT_CFLAGS)