summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGreg V <greg@unrelenting.technology>2017-12-17 22:04:36 +0300
committerDaniel Stone <daniels@collabora.com>2018-01-18 18:20:01 +0000
commit551b8054304159784cf4819737aae29d59bb1607 (patch)
tree7c730dde74b99f1a836fbb7782d95be93c8bd591 /Makefile.am
parentbac2c549f009fda3cf5e2aa6e7665be7511f8cad (diff)
downloadweston-551b8054304159784cf4819737aae29d59bb1607.tar.gz
weston-551b8054304159784cf4819737aae29d59bb1607.tar.bz2
weston-551b8054304159784cf4819737aae29d59bb1607.zip
Use $(SED) to make sure GNU sed is used
FreeBSD's default sed is not compatible with this expression. Reviewed-by: Daniel Stone <daniels@collabora.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 64cceec4..e224d606 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1619,7 +1619,7 @@ $(if $(findstring unstable,$1),unstable,stable)
endef
define protoname
-$(shell echo $1 | sed 's/\([a-z\-]\+\)-[a-z]\+-v[0-9]\+/\1/')
+$(shell echo $1 | $(SED) 's/\([a-z\-]\+\)-[a-z]\+-v[0-9]\+/\1/')
endef
protocol/%-protocol.c : $(WAYLAND_PROTOCOLS_DATADIR)/$$(call protostability,$$*)/$$(call protoname,$$*)/$$*.xml