summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 6 insertions, 14 deletions
diff --git a/configure.ac b/configure.ac
index adfb4b6..21bb6b2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,5 +1,8 @@
+# SPDX-License-Identifier: GPL-2.0
+# Copyright (c) 2009 Kay Sievers <kay.sievers@vrfy.org>
+
AC_INIT([usbutils],
- [007],
+ [013],
[linux-usb@vger.kernel.org])
AC_PREREQ(2.60)
AM_INIT_AUTOMAKE([check-news foreign 1.9 dist-bzip2])
@@ -12,19 +15,9 @@ AC_SYS_LARGEFILE
AC_CHECK_HEADERS([byteswap.h])
AC_CHECK_FUNCS([nl_langinfo iconv])
-AC_ARG_ENABLE(zlib,
- AS_HELP_STRING(--disable-zlib,disable support for zlib))
-
-HAVE_ZLIB=no
-AS_IF([test "x$enable_zlib" != "xno"],
- [AC_CHECK_LIB(z, inflateEnd, HAVE_ZLIB=yes)])
-AM_CONDITIONAL(HAVE_ZLIB, [test "$HAVE_ZLIB" = "yes"])
-
-AC_ARG_ENABLE(usbids,
- AS_HELP_STRING(--disable-usbids, [disable installing usb.ids @<:@default=install@:>@]))
-AM_CONDITIONAL([INSTALL_USBIDS], [test "x$enable_usbids" != "xno"])
+PKG_CHECK_MODULES(LIBUSB, libusb-1.0 >= 1.0.14)
-PKG_CHECK_MODULES(LIBUSB, libusb-1.0 >= 1.0.0)
+PKG_CHECK_MODULES(UDEV, libudev >= 196)
AC_CONFIG_HEADERS([config.h])
AC_CONFIG_FILES([
@@ -43,7 +36,6 @@ AC_MSG_RESULT([
mandir: ${mandir}
usb.ids: ${datadir}/usb.ids
- zlib: ${USE_ZLIB}
compiler: ${CC}
cflags: ${CFLAGS}