summaryrefslogtreecommitdiff
path: root/src/shared/meson.build
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2018-10-17 20:40:09 +0200
committerLennart Poettering <lennart@poettering.net>2018-10-26 10:52:41 +0200
commitd68c645bd3323ae1f0dfcb8fd74ea6b19681db8a (patch)
treeeff23147292bf0e0ee6066054b8e6e933ccd1b64 /src/shared/meson.build
parentcdd620e3460b08d1f5b80cefefef352de42fb792 (diff)
downloadsystemd-d68c645bd3323ae1f0dfcb8fd74ea6b19681db8a.tar.gz
systemd-d68c645bd3323ae1f0dfcb8fd74ea6b19681db8a.tar.bz2
systemd-d68c645bd3323ae1f0dfcb8fd74ea6b19681db8a.zip
core: rework serialization
Let's be more careful with what we serialize: let's ensure we never serialize strings that are longer than LONG_LINE_MAX, so that we know we can read them back with read_line(…, LONG_LINE_MAX, …) safely. In order to implement this all serialization functions are move to serialize.[ch], and internally will do line size checks. We'd rather skip a serialization line (with a loud warning) than write an overly long line out. Of course, this is just a second level protection, after all the data we serialize shouldn't be this long in the first place. While we are at it also clean up logging: while serializing make sure to always log about errors immediately. Also, (void)ify all calls we don't expect errors in (or catch errors as part of the general fflush_and_check() at the end.
Diffstat (limited to 'src/shared/meson.build')
-rw-r--r--src/shared/meson.build8
1 files changed, 5 insertions, 3 deletions
diff --git a/src/shared/meson.build b/src/shared/meson.build
index 83a2592c0a..c692f012b1 100644
--- a/src/shared/meson.build
+++ b/src/shared/meson.build
@@ -52,10 +52,10 @@ shared_sources = files('''
import-util.c
import-util.h
initreq.h
- install.c
- install.h
install-printf.c
install-printf.h
+ install.c
+ install.h
journal-util.c
journal-util.h
logs-show.c
@@ -78,6 +78,8 @@ shared_sources = files('''
resolve-util.c
resolve-util.h
seccomp-util.h
+ serialize.c
+ serialize.h
sleep-config.c
sleep-config.h
spawn-ask-password-agent.c
@@ -92,8 +94,8 @@ shared_sources = files('''
sysctl-util.h
tomoyo-util.c
tomoyo-util.h
- udev-util.h
udev-util.c
+ udev-util.h
uid-range.c
uid-range.h
utmp-wtmp.h