summaryrefslogtreecommitdiff
path: root/src/resolve/meson.build
diff options
context:
space:
mode:
authorIwan Timmer <irtimmer@gmail.com>2018-07-26 22:47:50 +0100
committerIwan Timmer <irtimmer@gmail.com>2018-07-27 21:23:17 +0100
commit096cbdce13b811f34726533d1a569912adc7cbec (patch)
treecdd10ccc2032850c291198a6e660cc1ddbe0a225 /src/resolve/meson.build
parentba6aaf572774a49ec2ece32fff492ed814d60922 (diff)
downloadsystemd-096cbdce13b811f34726533d1a569912adc7cbec.tar.gz
systemd-096cbdce13b811f34726533d1a569912adc7cbec.tar.bz2
systemd-096cbdce13b811f34726533d1a569912adc7cbec.zip
resolved: basic OpenSSL support for DNS-over-TLS
This provides basic OpenSSL support without optimizations like TCP Fast Open and TLS Session Tickets. Notice only a single SSL library can be enabled at a time and therefore journald functions provided by GnuTLS will be disabled when using OpenSSL. Fixes #9531
Diffstat (limited to 'src/resolve/meson.build')
-rw-r--r--src/resolve/meson.build11
1 files changed, 9 insertions, 2 deletions
diff --git a/src/resolve/meson.build b/src/resolve/meson.build
index 5955875f59..6d03ebf7f4 100644
--- a/src/resolve/meson.build
+++ b/src/resolve/meson.build
@@ -142,8 +142,15 @@ systemd_resolved_sources += [resolved_gperf_c, resolved_dnssd_gperf_c]
systemd_resolved_dependencies = [threads, libgpg_error, libm, libidn]
if conf.get('ENABLE_DNS_OVER_TLS') == 1
- systemd_resolved_sources += [files(['resolved-dnstls-gnutls.c', 'resolved-dnstls-gnutls.h'])]
- systemd_resolved_dependencies += [libgnutls]
+ if conf.get('DNS_OVER_TLS_USE_GNUTLS') == 1
+ systemd_resolved_sources += [files(['resolved-dnstls-gnutls.c', 'resolved-dnstls-gnutls.h'])]
+ systemd_resolved_dependencies += [libgnutls]
+ elif conf.get('DNS_OVER_TLS_USE_OPENSSL') == 1
+ systemd_resolved_sources += [files(['resolved-dnstls-openssl.c', 'resolved-dnstls-openssl.h'])]
+ systemd_resolved_dependencies += [libopenssl]
+ else
+ error('unknown dependency for supporting DNS-over-TLS')
+ endif
endif
if conf.get('ENABLE_RESOLVE') == 1