summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2018-06-25 16:07:33 +0200
committerLennart Poettering <lennart@poettering.net>2018-10-19 22:34:50 +0200
commitf876f53789380cb2c096e3c09401f7273387d1d2 (patch)
tree1a15cb86c3a4b258a7f9120d2fe1883c4b909e51 /meson.build
parent4b2d80bb0a9725a871aaec1d0abeeb4fee2c6eda (diff)
downloadsystemd-f876f53789380cb2c096e3c09401f7273387d1d2.tar.gz
systemd-f876f53789380cb2c096e3c09401f7273387d1d2.tar.bz2
systemd-f876f53789380cb2c096e3c09401f7273387d1d2.zip
units: add simple boot check unit
This is might be useful in some cases, but it's primarily an example for a boot check service that can be plugged before boot-complete.target. It's disabled by default. All it does is check whether the failed unit count is zero
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build9
1 files changed, 9 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 059a261813..7960e97893 100644
--- a/meson.build
+++ b/meson.build
@@ -1815,6 +1815,15 @@ if conf.get('ENABLE_EFI') == 1 and conf.get('HAVE_BLKID') == 1
install_dir : systemgeneratordir)
endif
+executable('systemd-boot-check-no-failures',
+ 'src/boot/boot-check-no-failures.c',
+ include_directories : includes,
+ link_with : [libshared],
+ dependencies : [libblkid],
+ install_rpath : rootlibexecdir,
+ install : true,
+ install_dir : rootlibexecdir)
+
exe = executable('systemd-socket-activate', 'src/activate/activate.c',
include_directories : includes,
link_with : [libshared],