summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2018-10-29 18:32:51 +0100
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2018-10-29 21:54:42 +0100
commite0a1d4b049e6991919a0eacd5d96f7f39dc6ddd1 (patch)
tree6f2d03921940d335d49d732e0d5a541c49308aa5 /meson.build
parent2b686260894ee0fda9ed75572735e750828605ca (diff)
downloadsystemd-e0a1d4b049e6991919a0eacd5d96f7f39dc6ddd1.tar.gz
systemd-e0a1d4b049e6991919a0eacd5d96f7f39dc6ddd1.tar.bz2
systemd-e0a1d4b049e6991919a0eacd5d96f7f39dc6ddd1.zip
Drop support for lz4 < 1.3.0
lz4-r130 was released on May 29th, 2015. Let's drop the work-around for older versions. In particular, we won't test any new code against those ancient releases, so we shouldn't pretend they are supported.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 3b01021562..a0e0305e02 100644
--- a/meson.build
+++ b/meson.build
@@ -1092,6 +1092,7 @@ conf.set10('HAVE_XZ', have)
want_lz4 = get_option('lz4')
if want_lz4 != 'false' and not fuzzer_build
liblz4 = dependency('liblz4',
+ version : '>= 1.3.0',
required : want_lz4 == 'true')
have = liblz4.found()
else