summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMichael Olbrich <m.olbrich@pengutronix.de>2018-11-11 11:30:53 +0100
committerMichael Olbrich <m.olbrich@pengutronix.de>2018-11-11 11:31:53 +0100
commitbe5536a6afdc610aa0eb2178e579157cb63336e7 (patch)
treecc1a3e160336f9c690a9348601b22f95775955a4 /meson.build
parent5996740a090b6f45f8545ef29583c88800681d0b (diff)
downloadsystemd-be5536a6afdc610aa0eb2178e579157cb63336e7.tar.gz
systemd-be5536a6afdc610aa0eb2178e579157cb63336e7.tar.bz2
systemd-be5536a6afdc610aa0eb2178e579157cb63336e7.zip
meson: fix building with -Ddns-over-tls=false
Assigning multiple variables in one line is no valid meson syntax. Without this running meson with -Ddns-over-tls=false fails with: meson.build:1191:8: ERROR: Tried to assign an invalid value to variable.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 3 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 78be291ae6..d3cea0cfdf 100644
--- a/meson.build
+++ b/meson.build
@@ -1188,7 +1188,9 @@ if dns_over_tls != 'false'
endif
have = have_gnutls or have_openssl
else
- have = have_gnutls = have_openssl = false
+ have = false
+ have_gnutls = false
+ have_openssl = false
endif
conf.set10('ENABLE_DNS_OVER_TLS', have)
conf.set10('DNS_OVER_TLS_USE_GNUTLS', have_gnutls)