summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMichael Biebl <biebl@debian.org>2018-07-13 23:36:13 +0200
committerMichael Biebl <biebl@debian.org>2018-07-13 23:38:55 +0200
commitace5e3111c0b8d8bfd84b32f2c689b0a4d92c061 (patch)
treea48e01b5cfa0880567e980e3ba9b4920e0b3d004 /meson.build
parentfa53e24130af3a389573acb9585eadbf7192955f (diff)
downloadsystemd-ace5e3111c0b8d8bfd84b32f2c689b0a4d92c061.tar.gz
systemd-ace5e3111c0b8d8bfd84b32f2c689b0a4d92c061.tar.bz2
systemd-ace5e3111c0b8d8bfd84b32f2c689b0a4d92c061.zip
Do not apply uaccess tag for /dev/kvm if mode is 0666
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 3 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index dd904c7148..2a70af0dcb 100644
--- a/meson.build
+++ b/meson.build
@@ -741,7 +741,9 @@ substs.set('USERS_GID', users_gid)
conf.set10('ENABLE_ADM_GROUP', get_option('adm-group'))
conf.set10('ENABLE_WHEEL_GROUP', get_option('wheel-group'))
-substs.set('DEV_KVM_MODE', get_option('dev-kvm-mode'))
+dev_kvm_mode = get_option('dev-kvm-mode')
+substs.set('DEV_KVM_MODE', dev_kvm_mode)
+conf.set10('DEV_KVM_UACCESS', dev_kvm_mode != '0666')
substs.set('GROUP_RENDER_MODE', get_option('group-render-mode'))
kill_user_processes = get_option('default-kill-user-processes')