summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorDimitri John Ledkov <xnox@ubuntu.com>2018-08-29 15:38:09 +0100
committerYu Watanabe <watanabe.yu+github@gmail.com>2018-08-29 23:38:09 +0900
commita9fc640671ef60ac949f1ace6fa687ff242fc233 (patch)
treed8542aa4611a2c880e6432a91b50b80d7d3e71b4 /meson.build
parent030836923d9f8600926b2a7dd24b249a540c31e6 (diff)
downloadsystemd-a9fc640671ef60ac949f1ace6fa687ff242fc233.tar.gz
systemd-a9fc640671ef60ac949f1ace6fa687ff242fc233.tar.bz2
systemd-a9fc640671ef60ac949f1ace6fa687ff242fc233.zip
cryptsetup: add support for sector-size= option (#9936)
Bug-Ubuntu: https://launchpad.net/bugs/1776626 Closes #8881.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index f4eabe7373..a76692d67b 100644
--- a/meson.build
+++ b/meson.build
@@ -924,11 +924,17 @@ if want_libcryptsetup != 'false' and not fuzzer_build
version : '>= 1.6.0',
required : want_libcryptsetup == 'true')
have = libcryptsetup.found()
+ have_sector = cc.has_member(
+ 'struct crypt_params_plain',
+ 'sector_size',
+ prefix : '#include <libcryptsetup.h>')
else
have = false
+ have_sector = false
libcryptsetup = []
endif
conf.set10('HAVE_LIBCRYPTSETUP', have)
+conf.set10('HAVE_LIBCRYPTSETUP_SECTOR_SIZE', have_sector)
want_libcurl = get_option('libcurl')
if want_libcurl != 'false' and not fuzzer_build