summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2018-10-11 18:23:26 +0200
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2018-10-17 14:40:39 +0200
commita8b627aaed409a15260c25988970c795bf963812 (patch)
tree2e911ab3ce9cff9aeec9265a4d911f2ddc11fcd9 /meson.build
parent52d363e32e935c8cbaab8e61ef776ff30f4e5cb9 (diff)
downloadsystemd-a8b627aaed409a15260c25988970c795bf963812.tar.gz
systemd-a8b627aaed409a15260c25988970c795bf963812.tar.bz2
systemd-a8b627aaed409a15260c25988970c795bf963812.zip
main: bump fs.nr_open + fs.max-file to their largest possible values
After discussions with kernel folks, a system with memcg really shouldn't need extra hard limits on file descriptors anymore, as they are properly accounted for by memcg anyway. Hence, let's bump these values to their maximums. This also adds a build time option to turn thiss off, to cover those users who do not want to use memcg.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 30834c86e3..ee8ab1ae29 100644
--- a/meson.build
+++ b/meson.build
@@ -73,6 +73,9 @@ sysvrcnd_path = get_option('sysvrcnd-path')
conf.set10('HAVE_SYSV_COMPAT', sysvinit_path != '' and sysvrcnd_path != '',
description : 'SysV init scripts and rcN.d links are supported')
+conf.set10('BUMP_PROC_SYS_FS_FILE_MAX', get_option('bump-proc-sys-fs-file-max'))
+conf.set10('BUMP_PROC_SYS_FS_NR_OPEN', get_option('bump-proc-sys-fs-nr-open'))
+
# join_paths ignore the preceding arguments if an absolute component is
# encountered, so this should canonicalize various paths when they are
# absolute or relative.