summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2019-03-05 12:12:33 +0100
committerLennart Poettering <lennart@poettering.net>2019-03-05 12:21:17 +0100
commit9e71f5d9838af32b9484d1757129c419e57866ae (patch)
tree771a1eb36a153322b6e9a943ff0b8b3ec09d7abb /meson.build
parent3a736a32164672550fead7417a2159751ac94df5 (diff)
downloadsystemd-9e71f5d9838af32b9484d1757129c419e57866ae.tar.gz
systemd-9e71f5d9838af32b9484d1757129c419e57866ae.tar.bz2
systemd-9e71f5d9838af32b9484d1757129c419e57866ae.zip
shutdown: rearrange shutdown sources in source tree
Let's move the shutdown binary into its own subdirectory in src/shutdown, after all it is relatively isolated from the normal PID 1 sources, being a different binary and all. Unfortunately it's not possible to move some of the code, since it is shared with PID 1, that I wished we could move, but I still think it's worth it.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 239f13c061..f2b975abc5 100644
--- a/meson.build
+++ b/meson.build
@@ -1441,6 +1441,7 @@ includes = include_directories('src/basic',
'src/udev',
'src/libudev',
'src/core',
+ 'src/shutdown',
'src/libsystemd/sd-bus',
'src/libsystemd/sd-device',
'src/libsystemd/sd-event',
@@ -1527,6 +1528,7 @@ public_programs = []
subdir('src/libudev')
subdir('src/shared')
subdir('src/core')
+subdir('src/shutdown')
subdir('src/udev')
subdir('src/network')
@@ -2676,6 +2678,10 @@ public_programs += exe
executable('systemd-shutdown',
systemd_shutdown_sources,
+ 'src/core/mount-setup.c',
+ 'src/core/mount-setup.h',
+ 'src/core/killall.c',
+ 'src/core/killall.h',
include_directories : includes,
link_with : [libshared],
dependencies : [libmount],