summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2017-04-11 10:25:34 -0400
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2017-04-23 21:47:27 -0400
commit9cc0e6e99ca3645b87c22fecdaa9ba9965a12e4f (patch)
treed2983b55e3e36dd00095d1593b559a1effa9128d /meson.build
parent3131bfe302d3d2657576499a86827ca979846b81 (diff)
downloadsystemd-9cc0e6e99ca3645b87c22fecdaa9ba9965a12e4f.tar.gz
systemd-9cc0e6e99ca3645b87c22fecdaa9ba9965a12e4f.tar.bz2
systemd-9cc0e6e99ca3645b87c22fecdaa9ba9965a12e4f.zip
meson: make cpp invocations cross-compilation friendly
This implementation assumes that the arguments in compiler.cmd_array() don't contain any spaces. Since we are only interested in compilation on Linux, I think this is a safe assumption. Solution suggested by Nirbheek Chauhan.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 57e439e733..8c01872a26 100644
--- a/meson.build
+++ b/meson.build
@@ -295,6 +295,8 @@ foreach arg : ['-Wl,-z,relro',
endif
endforeach
+cpp = ' '.join(cc.cmd_array()) + ' -E'
+
#####################################################################
# compilation result tests