summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2018-10-10 11:50:57 +0200
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2018-10-10 11:50:57 +0200
commit9b0ca01903ebc782d59c5526cd602a80e8367674 (patch)
treeb26bb4e44b05b37b14ea7b4dda0294675cf314d4 /meson.build
parentca92fe36e07d0d495baef1f860d66925bc0dc165 (diff)
downloadsystemd-9b0ca01903ebc782d59c5526cd602a80e8367674.tar.gz
systemd-9b0ca01903ebc782d59c5526cd602a80e8367674.tar.bz2
systemd-9b0ca01903ebc782d59c5526cd602a80e8367674.zip
meson: rename cpp_cmd to cxx_cmd
cpp is a really bad alias for c++ because it's also the name of the preprocessor. Let's rename the variable.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 51407098dc..0ebbfce430 100644
--- a/meson.build
+++ b/meson.build
@@ -278,9 +278,9 @@ cxx = find_program('c++', required : false)
if cxx.found()
# Used only for tests
add_languages('cpp')
- cpp_cmd = ' '.join(meson.get_compiler('cpp').cmd_array())
+ cxx_cmd = ' '.join(meson.get_compiler('cpp').cmd_array())
else
- cpp_cmd = ''
+ cxx_cmd = ''
endif
want_ossfuzz = get_option('oss-fuzz')