summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorTobias Jungel <Tobias.Jungel@gmail.com>2018-11-02 02:31:20 +0100
committerYu Watanabe <watanabe.yu+github@gmail.com>2018-11-02 10:31:20 +0900
commit99f68ef02d1e136457c2b0fd1a375050ff965af3 (patch)
treee820715240042c1671f0ca30ef7ed271e3e806ad /meson.build
parent9cbdf5db4836588c30310eba9470ced398207a1c (diff)
downloadsystemd-99f68ef02d1e136457c2b0fd1a375050ff965af3.tar.gz
systemd-99f68ef02d1e136457c2b0fd1a375050ff965af3.tar.bz2
systemd-99f68ef02d1e136457c2b0fd1a375050ff965af3.zip
networkd: add missing bonding options (#10542)
Add support for bonding options system prio, port key and actor system mac. These options exist in the linux kernel since 4.2 (torvalds/linux@171a42c38c6e1) Details: https://www.kernel.org/doc/Documentation/networking/bonding.txt
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index fcbb22b540..76add43146 100644
--- a/meson.build
+++ b/meson.build
@@ -455,7 +455,7 @@ foreach decl : [['IFLA_INET6_ADDR_GEN_MODE', 'linux/if_link.h'],
['IFLA_MACVLAN_FLAGS', 'linux/if_link.h'],
['IFLA_IPVLAN_FLAGS', 'linux/if_link.h'],
['IFLA_PHYS_PORT_ID', 'linux/if_link.h'],
- ['IFLA_BOND_AD_INFO', 'linux/if_link.h'],
+ ['IFLA_BOND_AD_ACTOR_SYSTEM', 'linux/if_link.h'],
['IFLA_VLAN_PROTOCOL', 'linux/if_link.h'],
['IFLA_VXLAN_REMCSUM_NOPARTIAL', 'linux/if_link.h'],
['IFLA_VXLAN_GPE', 'linux/if_link.h'],