summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2018-08-19 19:11:30 +0200
committerFilipe Brandenburger <filbranden@google.com>2018-08-20 16:10:57 -0700
commit8f6b442a78d0b485f044742ad90b2e8271b4e68e (patch)
tree306086498e748301d82454f75acb926cb3e59df3 /meson.build
parenta9e241dcb31f7752fb43299207072442e9bf33d2 (diff)
downloadsystemd-8f6b442a78d0b485f044742ad90b2e8271b4e68e.tar.gz
systemd-8f6b442a78d0b485f044742ad90b2e8271b4e68e.tar.bz2
systemd-8f6b442a78d0b485f044742ad90b2e8271b4e68e.zip
meson: rename -Ddebug to -Ddebug-extra
Meson added -Doptimization and -Ddebug options, which obviously causes a conflict with our -Ddebug options. Let's rename it. Fixes #9883.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index f79ac4b12e..2209c935ad 100644
--- a/meson.build
+++ b/meson.build
@@ -763,7 +763,7 @@ substs.set('DEBUGTTY', get_option('debug-tty'))
enable_debug_hashmap = false
enable_debug_mmap_cache = false
-foreach name : get_option('debug')
+foreach name : get_option('debug-extra')
if name == 'hashmap'
enable_debug_hashmap = true
elif name == 'mmap-cache'