summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2017-12-19 19:06:56 +0100
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2018-01-03 12:09:45 +0100
commit34e221a58bb3f4d5d58fe238a6a5e5a5df30d4ff (patch)
treec0a73faa2c20b7dc0c9a31fa3b3dd1d7d3431c2e /meson.build
parent2d4ceca8a5f606beed5f11b0d307913727590c00 (diff)
downloadsystemd-34e221a58bb3f4d5d58fe238a6a5e5a5df30d4ff.tar.gz
systemd-34e221a58bb3f4d5d58fe238a6a5e5a5df30d4ff.tar.bz2
systemd-34e221a58bb3f4d5d58fe238a6a5e5a5df30d4ff.zip
Move gcrypt-util to basic/
We were including gcrypt-util.[ch] by hand in the few places where it was used. Create a convenience library to avoid compiling the same files multiple times. v2: - use a separate static library instead of mergin into libbasic
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build18
1 files changed, 6 insertions, 12 deletions
diff --git a/meson.build b/meson.build
index 8ea3c03788..fa0b0abf74 100644
--- a/meson.build
+++ b/meson.build
@@ -1235,9 +1235,6 @@ includes = include_directories('src/basic',
add_project_arguments('-include', 'config.h', language : 'c')
-gcrypt_util_sources = files('src/shared/gcrypt-util.h',
- 'src/shared/gcrypt-util.c')
-
subdir('po')
subdir('catalog')
subdir('src/systemd')
@@ -1258,15 +1255,14 @@ libsystemd_sym_path = '@0@/@1@'.format(meson.current_source_dir(), libsystemd_sy
libsystemd = shared_library(
'systemd',
journal_internal_sources,
- gcrypt_util_sources,
version : libsystemd_version,
include_directories : includes,
link_args : ['-shared',
'-Wl,--version-script=' + libsystemd_sym_path],
- link_with : libbasic,
+ link_with : [libbasic,
+ libbasic_gcrypt],
link_whole : libsystemd_static,
dependencies : [threads,
- libgcrypt,
librt,
libxz,
liblz4],
@@ -1507,11 +1503,10 @@ endif
if conf.get('ENABLE_RESOLVE') == 1
executable('systemd-resolved',
systemd_resolved_sources,
- gcrypt_util_sources,
include_directories : includes,
- link_with : [libshared],
+ link_with : [libshared,
+ libbasic_gcrypt],
dependencies : [threads,
- libgcrypt,
libgpg_error,
libm,
libidn],
@@ -1521,11 +1516,10 @@ if conf.get('ENABLE_RESOLVE') == 1
exe = executable('systemd-resolve',
systemd_resolve_sources,
- gcrypt_util_sources,
include_directories : includes,
- link_with : [libshared],
+ link_with : [libshared,
+ libbasic_gcrypt],
dependencies : [threads,
- libgcrypt,
libgpg_error,
libm,
libidn],