summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2018-10-02 17:43:37 +0200
committerGitHub <noreply@github.com>2018-10-02 17:43:37 +0200
commit29088d374ebd5f9c210e4cc8f04155f0292295de (patch)
tree24eda18d5409afe9f59f7116ac5b065c0c550927 /meson.build
parenteb74d3b97aea128c30a51ae793d1d5bd7c0f65de (diff)
parent87d57be06f85859f3862e53d4389b520ad7eabc2 (diff)
downloadsystemd-29088d374ebd5f9c210e4cc8f04155f0292295de.tar.gz
systemd-29088d374ebd5f9c210e4cc8f04155f0292295de.tar.bz2
systemd-29088d374ebd5f9c210e4cc8f04155f0292295de.zip
Merge pull request #9898 from keszybz/id128
Add a new tool 'systemd-id128'
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 8 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 02e230415d..554e67e5dd 100644
--- a/meson.build
+++ b/meson.build
@@ -2324,6 +2324,14 @@ executable('systemd-cgroups-agent',
install : true,
install_dir : rootlibexecdir)
+exe = executable('systemd-id128',
+ 'src/id128/id128.c',
+ include_directories : includes,
+ link_with : [libshared],
+ install_rpath : rootlibexecdir,
+ install : true)
+public_programs += exe
+
exe = executable('systemd-path',
'src/path/path.c',
include_directories : includes,