summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2018-10-09 18:48:09 +0200
committerLennart Poettering <lennart@poettering.net>2018-10-09 21:12:00 +0200
commit1b2acaa7a642ad9b95e97f2752ce7c86874caaa0 (patch)
tree78867395dc5518d87abed2ba64644d76c9b9f98f /meson.build
parent13711093eff067a1cbb370f7e22ad390232154e1 (diff)
downloadsystemd-1b2acaa7a642ad9b95e97f2752ce7c86874caaa0.tar.gz
systemd-1b2acaa7a642ad9b95e97f2752ce7c86874caaa0.tar.bz2
systemd-1b2acaa7a642ad9b95e97f2752ce7c86874caaa0.zip
meson: we cannot call get_compiler('cpp') if we didn't "add" it
Follow-up for f6d783ac3d145f3f3ffc2023d4ad90f76cf7fe34.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index e3f06616b5..51407098dc 100644
--- a/meson.build
+++ b/meson.build
@@ -278,6 +278,9 @@ cxx = find_program('c++', required : false)
if cxx.found()
# Used only for tests
add_languages('cpp')
+ cpp_cmd = ' '.join(meson.get_compiler('cpp').cmd_array())
+else
+ cpp_cmd = ''
endif
want_ossfuzz = get_option('oss-fuzz')