summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2018-10-05 16:38:42 +0200
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2018-10-09 15:42:40 +0200
commit19d8c9c9b7b3507eb2fdcf668a85456a4ae0dbeb (patch)
treed7375f665052b07bbd8d02700423d7d5d06d5754 /meson.build
parentafbae3e9f23dc6682d48a1cc3585e8429ef07d8b (diff)
downloadsystemd-19d8c9c9b7b3507eb2fdcf668a85456a4ae0dbeb.tar.gz
systemd-19d8c9c9b7b3507eb2fdcf668a85456a4ae0dbeb.tar.bz2
systemd-19d8c9c9b7b3507eb2fdcf668a85456a4ae0dbeb.zip
meson: include more build settings in status output
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 554e67e5dd..1d5a4f924e 100644
--- a/meson.build
+++ b/meson.build
@@ -2981,6 +2981,10 @@ alt_time_epoch = run_command('date', '-Is', '-u', '-d',
status += [
'time epoch: @0@ (@1@)'.format(time_epoch, alt_time_epoch)]
+status += [
+ 'static libsystemd: @0@'.format(get_option('static-libsystemd')),
+ 'static libudev: @0@'.format(get_option('static-libudev'))]
+
# TODO:
# CFLAGS: ${OUR_CFLAGS} ${CFLAGS}
# CPPFLAGS: ${OUR_CPPFLAGS} ${CPPFLAGS}
@@ -3080,6 +3084,8 @@ foreach tuple : [
['debug mmap cache'],
['valgrind', conf.get('VALGRIND') == 1],
['trace logging', conf.get('LOG_TRACE') == 1],
+ ['link-udev-shared', get_option('link-udev-shared')],
+ ['link-systemctl-shared', get_option('link-systemctl-shared')],
]
if tuple.length() >= 2