summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2017-11-20 12:14:47 +0100
committerLennart Poettering <lennart@poettering.net>2017-11-20 12:14:47 +0100
commit18c8db140f917b7f4b8dff9e75fa21cff77ddd1e (patch)
tree3fd5a9a8ce58e8c6008c643c3d891b133e085c54 /meson.build
parentf9753b0c792054ce7ea3c6fa2221d5f1d0b79b3c (diff)
downloadsystemd-18c8db140f917b7f4b8dff9e75fa21cff77ddd1e.tar.gz
systemd-18c8db140f917b7f4b8dff9e75fa21cff77ddd1e.tar.bz2
systemd-18c8db140f917b7f4b8dff9e75fa21cff77ddd1e.zip
meson: add -Wimplicit-fallthrough=3 to compilation options (#7393)
At some point before gcc-7 was released, -Wimplicit-fallthrough=3 was included in -Wextra. The documentation for gcc-7.2.1-2.fc27.x86_64 still says that, but empirical testing shows that it's not. The documentation also misstates that -Wimplicit-fallthrough is equivalent to -Wimplicit-fallthrough=3. Let's add -Wimplicit-fallthrough=3 explicitly to get the warnings if we regress. Prompted by #7389.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index f376d030fd..b038d6df82 100644
--- a/meson.build
+++ b/meson.build
@@ -271,6 +271,7 @@ foreach arg : ['-Wextra',
'-Wstrict-prototypes',
'-Wredundant-decls',
'-Wmissing-noreturn',
+ '-Wimplicit-fallthrough=3',
'-Wshadow',
'-Wendif-labels',
'-Wstrict-aliasing=2',