summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2018-08-21 16:08:48 +0200
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2018-10-02 15:15:10 +0200
commit0d1d512f7f42071595f0c950f911f3557fda09ea (patch)
treea2a35f4f32b83852fcef63b79ca768c82045b699 /meson.build
parent65d410c7cac1cdb312fd44ac5b4e8bb49f8a5f6f (diff)
downloadsystemd-0d1d512f7f42071595f0c950f911f3557fda09ea.tar.gz
systemd-0d1d512f7f42071595f0c950f911f3557fda09ea.tar.bz2
systemd-0d1d512f7f42071595f0c950f911f3557fda09ea.zip
systemd-id128: a new tool to print machine/boot/invocation/app-specific ids
The raison d'etre for this program is printing machine-app-specific IDs. We provide a library function for that, but not a convenient API. We can hardly ask people to quickly hack their own C programs or call libsystemd through CFFI in python or another scripting language if they just want to print an ID. Verb 'new' was already available as 'journalctl --new-id128', but this makes it more discoverable. v2: - rename binary to systemd-id128 - make --app-specific= into a switch that applies to boot-id and machine-id
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 8 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 1c4febfa4b..49da6825e0 100644
--- a/meson.build
+++ b/meson.build
@@ -2323,6 +2323,14 @@ executable('systemd-cgroups-agent',
install : true,
install_dir : rootlibexecdir)
+exe = executable('systemd-id128',
+ 'src/id128/id128.c',
+ include_directories : includes,
+ link_with : [libshared],
+ install_rpath : rootlibexecdir,
+ install : true)
+public_programs += exe
+
exe = executable('systemd-path',
'src/path/path.c',
include_directories : includes,