summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2018-08-08 14:50:57 +0200
committerLennart Poettering <lennart@poettering.net>2018-10-13 12:59:29 +0200
commit07ee5adb356b9fde500c8a5226f24a314789832b (patch)
treec87b7bdf19447cb22c58e5c41ede5b83d6af2acb /meson.build
parent3d0ef5c7e00155bc74f6f71c34cad518a4ff56ba (diff)
downloadsystemd-07ee5adb356b9fde500c8a5226f24a314789832b.tar.gz
systemd-07ee5adb356b9fde500c8a5226f24a314789832b.tar.bz2
systemd-07ee5adb356b9fde500c8a5226f24a314789832b.zip
logind: change user-runtime-dir to query runtime dir size from logind via the bus
I think this is a slightly cleaner approach than parsing the configuration file at multiple places, as this way there's only a single reload cycle for logind.conf, and that's systemd-logind.service's runtime. This means that logind and dbus become a requirement of user-runtime-dir, but given that XDG_RUNTIME_DIR is not set anyway without logind and dbus around this isn't really any limitation. This also simplifies linking a bit as this means user-runtime-dir doesn't have to link against any code of logind itself.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build16
1 files changed, 8 insertions, 8 deletions
diff --git a/meson.build b/meson.build
index 39c427cd26..30834c86e3 100644
--- a/meson.build
+++ b/meson.build
@@ -1762,15 +1762,15 @@ if conf.get('ENABLE_LOGIND') == 1
args : pam_systemd.full_path())
endif
endif
-endif
-executable('systemd-user-runtime-dir',
- user_runtime_dir_sources,
- include_directories : includes,
- link_with : [libshared, liblogind_core],
- install_rpath : rootlibexecdir,
- install : true,
- install_dir : rootlibexecdir)
+ executable('systemd-user-runtime-dir',
+ user_runtime_dir_sources,
+ include_directories : includes,
+ link_with : [libshared],
+ install_rpath : rootlibexecdir,
+ install : true,
+ install_dir : rootlibexecdir)
+endif
if conf.get('HAVE_PAM') == 1
executable('systemd-user-sessions',