summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml66
1 files changed, 66 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..2628cdf
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,66 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+rust-version = "1.47"
+name = "async-executor"
+version = "1.5.0"
+authors = ["Stjepan Glavina <stjepang@gmail.com>"]
+exclude = ["/.*"]
+description = "Async executor"
+readme = "README.md"
+keywords = [
+ "asynchronous",
+ "executor",
+ "single",
+ "multi",
+ "spawn",
+]
+categories = [
+ "asynchronous",
+ "concurrency",
+]
+license = "Apache-2.0 OR MIT"
+repository = "https://github.com/smol-rs/async-executor"
+
+[dependencies.async-lock]
+version = "2.6"
+
+[dependencies.async-task]
+version = "4.0.0"
+
+[dependencies.concurrent-queue]
+version = "2.0.0"
+
+[dependencies.fastrand]
+version = "1.3.4"
+
+[dependencies.futures-lite]
+version = "1.11.0"
+
+[dependencies.slab]
+version = "0.4.4"
+
+[dev-dependencies.async-channel]
+version = "1.4.1"
+
+[dev-dependencies.async-io]
+version = "1.1.9"
+
+[dev-dependencies.easy-parallel]
+version = "3.1.0"
+
+[dev-dependencies.num_cpus]
+version = "1.13.0"
+
+[dev-dependencies.once_cell]
+version = "1.16.0"