summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWayne Davison <wayned@samba.org>2010-12-19 08:54:11 -0800
committerWayne Davison <wayned@samba.org>2010-12-19 08:54:11 -0800
commit3f770ab0a5922604392808109fb778d31ec78bf2 (patch)
tree78f360da76b874417cdeff64e3ae89146258d807 /configure.ac
parent743348e848915aa1217d970bd5673364345174e0 (diff)
downloadrsync-3f770ab0a5922604392808109fb778d31ec78bf2.tar.gz
rsync-3f770ab0a5922604392808109fb778d31ec78bf2.tar.bz2
rsync-3f770ab0a5922604392808109fb778d31ec78bf2.zip
Set NO_SYMLINK_XATTRS on linux the easy way.
Fixes bug 7109.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 5 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 9de88d15..f90109a0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -46,7 +46,7 @@ AC_DEFINE([_GNU_SOURCE], 1,
[Define _GNU_SOURCE so that we get all necessary prototypes])
if test x"$ac_cv_prog_cc_stdc" = x"no"; then
- AC_MSG_WARN([rsync requires an ANSI C compiler and you don't seem to have one])
+ AC_MSG_WARN([rsync requires an ANSI C compiler and you do not seem to have one])
fi
AC_ARG_ENABLE(profile,
@@ -199,7 +199,7 @@ ipv6trylibc=yes
AC_ARG_ENABLE(ipv6,
AC_HELP_STRING([--disable-ipv6],
- [don't even try to use IPv6]))
+ [do not even try to use IPv6]))
if test x"$enable_ipv6" != x"no"; then
AC_MSG_CHECKING([ipv6 stack type])
for i in inria kame linux-glibc linux-inet6 solaris toshiba v6d zeta cygwin; do
@@ -313,7 +313,7 @@ AC_ARG_ENABLE([locale],
AC_HELP_STRING([--disable-locale],
[disable locale features]))
AH_TEMPLATE([CONFIG_LOCALE],
-[Undefine if you don't want locale features. By default this is defined.])
+[Undefine if you do not want locale features. By default this is defined.])
if test x"$enable_locale" != x"no"; then
AC_DEFINE(CONFIG_LOCALE)
fi
@@ -981,6 +981,7 @@ else
AC_MSG_RESULT(Using Linux xattrs)
AC_DEFINE(HAVE_LINUX_XATTRS, 1, [True if you have Linux xattrs])
AC_DEFINE(SUPPORT_XATTRS, 1)
+ AC_DEFINE(NO_SYMLINK_XATTRS, 1, [True if symlinks do not support xattrs])
;;
darwin*)
AC_MSG_RESULT(Using OS X xattrs)
@@ -996,7 +997,7 @@ else
AC_MSG_RESULT(Using Solaris xattrs)
AC_DEFINE(HAVE_SOLARIS_XATTRS, 1, [True if you have Solaris xattrs])
AC_DEFINE(SUPPORT_XATTRS, 1)
- AC_DEFINE(NO_SYMLINK_XATTRS, 1, [True if symlinks don't support xattrs])
+ AC_DEFINE(NO_SYMLINK_XATTRS, 1)
;;
*)
if test x"$enable_xattr_support" = x"yes"; then