Age | Commit message (Collapse) | Author | Files | Lines | |
---|---|---|---|---|---|
2011-03-10 | Move string hash function to librpmio and rename for namespacing | Panu Matilainen | 1 | -24/+0 | |
- There are places in rpmio and build that would benefit from hashing, but hashFunctionString() being internal to librpm has prevented that. Rename to rstrhash() to resemble the other foo in rpmstring.h for minimal namespacing as its now public function and update callers. - Also mark the function as "pure" - it only looks at its arguments. This is one of the busiest functions in entire rpm so any optimization no matter how minor is well worth it. - Hereby awarding hashFunctionString() with the grand prize for the Most Moved Around Function in rpm ;) | |||||
2010-12-15 | Split user+group caching to separate source (again), rename | Panu Matilainen | 1 | -162/+0 | |
- We'll want to unify this and the similar caching done in librpmbuild, so we need to expose these in the ABI at least, rename to get them namespaced and use a separate source module (again) as this is a pretty distinct functionality. - This would really belong to librpmio but leaving here for now... | |||||
2010-12-14 | Remove hardcoded lock and mail group id's | Panu Matilainen | 1 | -9/+0 | |
- Rpm has no business making assumptions about arbitrary group id's, if these are not available through getgrname() when needed, that's a packaging problem. | |||||
2010-09-21 | Move the RPMVERSION constant among its friends in depends.c | Panu Matilainen | 1 | -3/+0 | |
- Doesn't make any difference, just grouping similar goo in one spot. | |||||
2010-05-21 | Move the lone hashFunctionString() into misc.[ch], eliminate rpmhash.[ch] | Panu Matilainen | 1 | -0/+17 | |
- Besides there not being much point in having a separate source + header for a small single function, this fixes build on case-insensitive systems such as Mac OS X. | |||||
2009-12-23 | Dont include <pwd.h> from system.h, dont bother checking for it either | Panu Matilainen | 1 | -0/+1 | |
- no much point conditionalizing something we can't live without - just three places need, no point polluting include space everywhere | |||||
2009-12-23 | Dont include grp.h from system.h, dont bother checking in configure either | Panu Matilainen | 1 | -4/+4 | |
- no much point conditionalizing something we can't live without - just two places need, no point polluting include space everywhere | |||||
2009-08-31 | Replace equal/not equal uses of str[n]cmp() with rstreq[n] in misc helpers | Panu Matilainen | 1 | -6/+7 | |
2008-10-10 | And out goes rpmMkdirPath() | Panu Matilainen | 1 | -21/+0 | |
2008-07-04 | Stuff rpmio/ugid.[ch] contents to lib/misc.[ch] | Panu Matilainen | 1 | -0/+163 | |
- no uses outside librpm itself, and there they can be hidden away from exported ABI whereas in librpmio they cant | |||||
2008-06-03 | Rip doputenv() for good | Panu Matilainen | 1 | -9/+0 | |
2008-06-03 | Rip dosetenv() | Panu Matilainen | 1 | -12/+0 | |
- just use regular setenv() instead - we already carry setenv() in misc/ for platforms that don't have it | |||||
2008-04-04 | Rip the url-craziness in rpmMkdirPath() | Panu Matilainen | 1 | -15/+1 | |
2008-04-04 | Rename currentDirectory() to rpmGetCwd() and move to librpmio | Panu Matilainen | 1 | -14/+0 | |
2008-03-07 | Further constants made readonly... | Panu Matilainen | 1 | -1/+1 | |
2008-01-30 | Include spring-cleaning | Panu Matilainen | 1 | -0/+2 | |
- put some consistency into include ordering - everything (apart from bits missed ;) is now ordered like this 1. "system.h" 2. other system includes 3. rpm public headers 4. rpm private headers 5. "debug.h" | |||||
2008-01-30 | rpmlib.h mass eviction | Panu Matilainen | 1 | -1/+0 | |
- explicitly include what's really needed instead - document remaining uses | |||||
2007-12-08 | Switch to <rpm/foo.h> style for public headers | Panu Matilainen | 1 | -4/+4 | |
- adjust include paths accordingly | |||||
2007-12-03 | Use regular POSIX functions instead of "RPC" clones | Panu Matilainen | 1 | -3/+3 | |
- we only care about local files | |||||
2007-11-23 | Expand private include file names to be relative to $(top_srcdir) | Ralf Corsépius | 1 | -1/+1 | |
2007-11-22 | Move makeTempFile() from misc.h to rpmfileutil.h | Panu Matilainen | 1 | -99/+0 | |
- probably not very useful outside rpm but used all over the tree, - rename to rpmMkTempFile() for namespacing since we're exporting it now | |||||
2007-11-23 | Move string helpers from lib/misc.h to rpmio/rpmstring.h | Panu Matilainen | 1 | -43/+0 | |
- splitString, freeSplitString, stripTrailingChar | |||||
2007-11-23 | Use #include <x.h> syntax to include public headers. | Ralf Corsépius | 1 | -4/+4 | |
2007-11-19 | Lose rpmerr.h for good | Panu Matilainen | 1 | -1/+1 | |
2007-11-19 | Replace all RPMERR_* etc uses with corresponding RPMLOG_* levels | Panu Matilainen | 1 | -5/+5 | |
2007-11-01 | Remove two unnecessary legacy.h includes | Panu Matilainen | 1 | -1/+0 | |
2007-10-28 | Include "rpmlib.h" instead of <rpmlib.h>. | Ralf Corsépius | 1 | -1/+1 | |
2007-10-28 | Include "rpmmacro.h" instead of <rpmmacro.h>. | Ralf Corsépius | 1 | -1/+1 | |
2007-10-28 | Include "rpmurl.h" instead of <rpmurl.h>. | Ralf Corsépius | 1 | -1/+1 | |
2007-10-22 | Remove bunch of unnecessary rpmio_internal includes | Panu Matilainen | 1 | -1/+0 | |
2007-10-09 | Make rpmerr.h private, include directly where needed. | Panu Matilainen | 1 | -0/+1 | |
2007-10-09 | Replace all rpmError() uses with rpmlog() | Panu Matilainen | 1 | -5/+5 | |
2007-09-20 | Remove the "dressed" rpmHeaderGetEntry() from API | Panu Matilainen | 1 | -51/+0 | |
- only used by the python bindings, move it there... | |||||
2007-09-11 | Remove splint tags. | Ralf Corsépius | 1 | -21/+6 | |
2007-08-31 | Use LOCALSTATEDIR instead of hard-coded /var. | Ralf Corsépius | 1 | -1/+1 | |
2004-11-28 | - add support for automagic pubkey retrieval using HKP. | jbj | 1 | -0/+2 | |
CVS patchset: 7617 CVS date: 2004/11/28 21:14:41 | |||||
2004-11-04 | Stub in URL_IS_HTTPS everywhere. | jbj | 1 | -2/+5 | |
CVS patchset: 7536 CVS date: 2004/11/04 13:29:11 | |||||
2004-03-02 | - permit globs in macrofiles: directive (#117217). | jbj | 1 | -155/+0 | |
CVS patchset: 7139 CVS date: 2004/03/02 01:31:01 | |||||
2003-06-04 | Remove dead code. | jbj | 1 | -8/+1 | |
CVS patchset: 6894 CVS date: 2003/06/04 19:28:27 | |||||
2003-04-02 | Splint clean. | jbj | 1 | -0/+10 | |
CVS patchset: 6729 CVS date: 2003/04/02 21:16:26 | |||||
2003-02-03 | oops, get rid of debugging printf's. | jbj | 1 | -7/+6 | |
destroy nptl functional test mutex/cond iff successful. initialize getcwd buffer to zero to keep valgrind happy. CVS patchset: 6035 CVS date: 2003/02/03 11:46:52 | |||||
2003-01-23 | splint fiddles. | jbj | 1 | -4/+1 | |
CVS patchset: 6023 CVS date: 2003/01/23 20:23:24 | |||||
2002-12-18 | - add --file{class,provide,require} popt aliases and header extensions | jbj | 1 | -2/+2 | |
CVS patchset: 5947 CVS date: 2002/12/18 22:54:00 | |||||
2002-08-13 | - fix: rebuilddb stat'ed target, not source, for rename sanity. | jbj | 1 | -51/+1 | |
- create /var/lib/rpm if non-existent in, say, a chroot. - erased packages are now repackaged into /var/spool/repackage. CVS patchset: 5625 CVS date: 2002/08/13 20:40:32 | |||||
2002-07-08 | Propagate splint-3.0.1.7 close(2) internalState annotation throughout. | jbj | 1 | -2/+2 | |
CVS patchset: 5542 CVS date: 2002/07/08 14:21:26 | |||||
2002-07-04 | - fix: forgot lazy open of database on --freshen path (#67907). | jbj | 1 | -0/+32 | |
- proof-of-concept rpmcache functionality. CVS patchset: 5539 CVS date: 2002/07/04 21:08:05 | |||||
2002-07-02 | Add boundsread annotations throughout, enable +bounds checking. | jbj | 1 | -2/+0 | |
Start narrowing the scope of bounds annotations by adding more annotations. CVS patchset: 5537 CVS date: 2002/07/02 23:54:35 | |||||
2002-06-28 | - rescusitate remote ftp globs (#67678). | jbj | 1 | -2/+2 | |
CVS patchset: 5533 CVS date: 2002/06/28 23:58:34 | |||||
2002-06-22 | Factor bounds checking annotations into source code. | jbj | 1 | -0/+2 | |
CVS patchset: 5521 CVS date: 2002/06/22 18:51:56 | |||||
2002-06-19 | Annotate incondefs in source code. | jbj | 1 | -0/+2 | |
CVS patchset: 5509 CVS date: 2002/06/19 18:52:46 |