summaryrefslogtreecommitdiff
path: root/build/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'build/Makefile.am')
-rw-r--r--build/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/build/Makefile.am b/build/Makefile.am
index 211fb8586..6f943e661 100644
--- a/build/Makefile.am
+++ b/build/Makefile.am
@@ -30,6 +30,11 @@ install-data-local:
sed -e "s|^dependency_libs='|& -lrpm|" < librpmbuild.la > .librpmbuild.la && \
mv .librpmbuild.la librpmbuild.la
+BUILT_SOURCES = rpmbuild.lcd
+
+rpmbuild.lcd: Makefile.am ${librpmbuild_la_SOURCES} ${pkginc_HEADERS} ${noinst_HEADERS}
+ -lclint ${DEFS} ${INCLUDES} ${librpmbuild_la_SOURCES} -dump $@ 2>/dev/null
+
.PHONY: sources
sources:
@echo $(librpmbuild_la_SOURCES:%=build/%)