summaryrefslogtreecommitdiff
path: root/rpmio/Makefile.am
diff options
context:
space:
mode:
authorPanu Matilainen <pmatilai@redhat.com>2010-02-10 10:52:40 +0200
committerPanu Matilainen <pmatilai@redhat.com>2010-02-10 11:20:51 +0200
commit87c237bebfc792a8b439fa2c5a2b78328b139d50 (patch)
tree6f4368c590cff4f3c2e60bb3510ebe10e67db77c /rpmio/Makefile.am
parenta79822f382c2e9e5002e7b411fa556c999fdc331 (diff)
downloadrpm-87c237bebfc792a8b439fa2c5a2b78328b139d50.tar.gz
rpm-87c237bebfc792a8b439fa2c5a2b78328b139d50.tar.bz2
rpm-87c237bebfc792a8b439fa2c5a2b78328b139d50.zip
Split elf dependency extraction out of librpmbuild to external helper
- Elf dependency extraction code code lifted from rpmfcELF() and refactored to saner pieces. Having it in separate executable also frees librpmbuild of libelf dependency, clean up the unnecessary linkage etc from autofoo - This lets internal dependency generator for elf files be overridden without losing file coloring (which is required for correct multilib handling). It also permits non-native elf files (eg when cross-building) to be handled by providing a custom elf dependency helper - On the flip side, this inevitably slows down builds somewhat as two fork-exec's are needed for every elf file, but unlike invoking something like the python interpreter, this is a slim helper... - All dependency extractors of the internal dependency generator are now external helpers (how twisted is that, huh? :) and thus can be customized and filtered through %__foo_provides|requires macros
Diffstat (limited to 'rpmio/Makefile.am')
-rw-r--r--rpmio/Makefile.am1
1 files changed, 0 insertions, 1 deletions
diff --git a/rpmio/Makefile.am b/rpmio/Makefile.am
index 05edd7a8f..b811130a5 100644
--- a/rpmio/Makefile.am
+++ b/rpmio/Makefile.am
@@ -5,7 +5,6 @@ AM_CPPFLAGS += @WITH_NSS_INCLUDE@
AM_CPPFLAGS += @WITH_LUA_INCLUDE@
AM_CPPFLAGS += @WITH_POPT_INCLUDE@
AM_CPPFLAGS += -I$(top_srcdir)/misc
-AM_CPPFLAGS += @WITH_LIBELF_INCLUDE@
AM_CPPFLAGS += -DRPMCONFIGDIR="\"@RPMCONFIGDIR@\""
AM_CPPFLAGS += -DLOCALSTATEDIR="\"$(localstatedir)\""