summaryrefslogtreecommitdiff
path: root/rpmio/Makefile.am
diff options
context:
space:
mode:
authorPanu Matilainen <pmatilai@redhat.com>2009-12-07 13:35:53 +0200
committerPanu Matilainen <pmatilai@redhat.com>2009-12-07 13:35:53 +0200
commit7a2395941e3eb81740f6b7b5d417991ef9b42fa4 (patch)
treed760a3c3c54ef9d18762e9e809730e89a5ae1403 /rpmio/Makefile.am
parent75c171f20891e58f1f14f37bba8e3e13b47bb783 (diff)
downloadrpm-7a2395941e3eb81740f6b7b5d417991ef9b42fa4.tar.gz
rpm-7a2395941e3eb81740f6b7b5d417991ef9b42fa4.tar.bz2
rpm-7a2395941e3eb81740f6b7b5d417991ef9b42fa4.zip
Bump soname for all our libraries
- while the "really public" API of librpmio has only been enhanced, librpm and librpmbuild use some supposedly internal bits which *have* changed considerably, so just to prevent anybody thinking they can combine librpmio from rpm 4.7 and librpm from this... - librpmbuild hasn't seen much real change but some (unfortunately) exposed struct members have changed so... - librpm is mostly compatible but as rpmal has become internal API, we need to bump (annoyingly, as nothing actually uses rpmal ... sigh)
Diffstat (limited to 'rpmio/Makefile.am')
-rw-r--r--rpmio/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/rpmio/Makefile.am b/rpmio/Makefile.am
index be75e306e..05edd7a8f 100644
--- a/rpmio/Makefile.am
+++ b/rpmio/Makefile.am
@@ -19,7 +19,7 @@ librpmio_la_SOURCES = \
rpmstring.c rpmfileutil.c \
rpmkeyring.c
-librpmio_la_LDFLAGS = -version-info 0:0:0
+librpmio_la_LDFLAGS = -version-info 1:0:0
librpmio_la_LIBADD = \
../misc/libmisc.la \
@WITH_NSS_LIB@ \