summaryrefslogtreecommitdiff
path: root/rpmio/Makefile.am
diff options
context:
space:
mode:
authorPanu Matilainen <pmatilai@redhat.com>2011-11-04 16:28:50 +0200
committerPanu Matilainen <pmatilai@redhat.com>2011-11-04 16:49:01 +0200
commit3db9a10577f1868bcf6cc15fe76a03851af39355 (patch)
tree3d4373987891c50b0a6a30a02e6a2cd9e56c6470 /rpmio/Makefile.am
parent85b90e4176cd32eee912cbefdc4438c801b7edbf (diff)
downloadrpm-3db9a10577f1868bcf6cc15fe76a03851af39355.tar.gz
rpm-3db9a10577f1868bcf6cc15fe76a03851af39355.tar.bz2
rpm-3db9a10577f1868bcf6cc15fe76a03851af39355.zip
Bury all NSS specifics into a separate source
- Not everybody needs/wants the certified monster that NSS is (along with all its quirks), this leaves room for alternative compile-time selectable crypto backends. Besides that, we get a clean functionality separation for the PGP parser and the cryptography parts. - The whole crypto abstraction works inspired + somewhat based on Michael Schroeder's similar patch in Suse, kudos. - TODO: port beecrypt support from Suse to the new interface.
Diffstat (limited to 'rpmio/Makefile.am')
-rw-r--r--rpmio/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/rpmio/Makefile.am b/rpmio/Makefile.am
index fee340836..2db6e6a2b 100644
--- a/rpmio/Makefile.am
+++ b/rpmio/Makefile.am
@@ -17,6 +17,8 @@ librpmio_la_SOURCES = \
rpmstring.c rpmfileutil.c \
rpmkeyring.c
+librpmio_la_SOURCES += digest_nss.c
+
librpmio_la_LDFLAGS = -version-info 2:0:0
librpmio_la_LIBADD = \
../misc/libmisc.la \