summaryrefslogtreecommitdiff
path: root/perl/Makefile.PL
diff options
context:
space:
mode:
authorjbj <devnull@localhost>2000-03-09 18:13:02 +0000
committerjbj <devnull@localhost>2000-03-09 18:13:02 +0000
commite93943f1e01bb8898e8445fb3ab1a648d1be7b68 (patch)
treed57dfc135fe862393bf6e12cb449a4ebabc3d399 /perl/Makefile.PL
parentacdafeca5ca650d1944e45b94bc6a60ff3fb67a2 (diff)
downloadrpm-e93943f1e01bb8898e8445fb3ab1a648d1be7b68.tar.gz
rpm-e93943f1e01bb8898e8445fb3ab1a648d1be7b68.tar.bz2
rpm-e93943f1e01bb8898e8445fb3ab1a648d1be7b68.zip
- portability: skip bzip2 if not available.
- portability: skip gzseek if not available (zlib-1.0.4). - portability: skip personality if not available (linux). - portability: always include arpa/inet.h (HP-UX). - portability: don't use id -u (Brandon Allbery). - portability: don't chown/chgrp -h w/o lchown. - portability: splats in rpm.spec to find /usr/{share,local}/locale/* CVS patchset: 3610 CVS date: 2000/03/09 18:13:02
Diffstat (limited to 'perl/Makefile.PL')
-rw-r--r--perl/Makefile.PL2
1 files changed, 1 insertions, 1 deletions
diff --git a/perl/Makefile.PL b/perl/Makefile.PL
index 4ec6c1897..02baf9f40 100644
--- a/perl/Makefile.PL
+++ b/perl/Makefile.PL
@@ -8,7 +8,7 @@ WriteMakefile(
'OBJECT' => 'rpm.o constant.o',
'VERSION_FROM' => 'rpm.pm', # finds $VERSION
'MAKEFILE'=> 'PMakefile',
- 'LIBS' => [' -L/usr/local/lib -ldb1 -lz'], # e.g., '-lm'
+ 'LIBS' => [' -L/usr/local/lib -ldb1 -lz -lbz2'], # e.g., '-lm'
'CCFLAGS' => '-g -O2 -D_GNU_SOURCE -Wall -Wpointer-arith -Wstrict-prototypes -Wmissing-prototypes -Wno-char-subscripts',
'OPTIMIZE'=> '-g',
'DEFINE' => '-Dbool=char -DHAS_BOOL',