summaryrefslogtreecommitdiff
path: root/perl/Makefile.PL
diff options
context:
space:
mode:
authorgafton <devnull@localhost>1999-07-28 00:56:34 +0000
committergafton <devnull@localhost>1999-07-28 00:56:34 +0000
commitc789b859108907d135a37c3acc030755678ba76b (patch)
tree57136a9816921fc8a5be38d7e001ef5d7b41393f /perl/Makefile.PL
parent3952d8e797bae56a0122ef96b2361686305c4852 (diff)
downloadrpm-c789b859108907d135a37c3acc030755678ba76b.tar.gz
rpm-c789b859108907d135a37c3acc030755678ba76b.tar.bz2
rpm-c789b859108907d135a37c3acc030755678ba76b.zip
Finally fixed it up for the new version of perl.
CVS patchset: 3207 CVS date: 1999/07/28 00:56:34
Diffstat (limited to 'perl/Makefile.PL')
-rw-r--r--perl/Makefile.PL10
1 files changed, 4 insertions, 6 deletions
diff --git a/perl/Makefile.PL b/perl/Makefile.PL
index f070fbf42..0caf7df2f 100644
--- a/perl/Makefile.PL
+++ b/perl/Makefile.PL
@@ -4,15 +4,13 @@ use ExtUtils::MakeMaker;
WriteMakefile(
'NAME' => 'rpm',
- 'OBJECT' => 'rpm.o constant.o /usr/lib/libdb1.a',
- 'VERSION_FROM' => 'rpm.pm', # finds $VERSION
- 'LIBS' => ['-lrpm -lz -ldb1'], # e.g., '-lm'
+ 'OBJECT' => 'rpm.o constant.o',
+ 'VERSION_FROM' => 'rpm.pm', # finds $VERSION
+ 'LIBS' => ['-lrpm -lz -ldb1'], # e.g., '-lm'
'CCFLAGS' => '-Dbool=char -DHAS_BOOL',
'OPTIMIZE'=> '-g',
'DEFINE' => '-Wall',
- 'INC' => '-I/usr/include/rpm', # e.g., '-I/usr/include/other'
+ 'INC' => '-I/usr/include/rpm', # e.g., '-I/usr/include/other'
'depend' => { 'rpm.c' => 'transaction.xs header.xs db.xs' },
);
-# $self->{'MAP_PRELIBS'} = ['-lnsl -lndbm -lgdbm -ldb1 -ldl -lm -lc -lposix -lcrypt -lrpm -lz'];
-