summaryrefslogtreecommitdiff
path: root/perl/Makefile.PL
diff options
context:
space:
mode:
authorjbj <devnull@localhost>2000-02-27 23:40:36 +0000
committerjbj <devnull@localhost>2000-02-27 23:40:36 +0000
commita217056e70d56a4eb666bda599d89ba2a4e0a014 (patch)
tree1a1578eae41837852321ce24f1f71c5125396d7e /perl/Makefile.PL
parent2fdcb4810f0edef7fbb11eb60e7c7336982419c6 (diff)
downloadrpm-a217056e70d56a4eb666bda599d89ba2a4e0a014.tar.gz
rpm-a217056e70d56a4eb666bda599d89ba2a4e0a014.tar.bz2
rpm-a217056e70d56a4eb666bda599d89ba2a4e0a014.zip
Permit building w/o libbz2.a.
In popt, check for building within the rpm tree before requiring GNU gettext. CVS patchset: 3595 CVS date: 2000/02/27 23:40:36
Diffstat (limited to 'perl/Makefile.PL')
-rw-r--r--perl/Makefile.PL4
1 files changed, 2 insertions, 2 deletions
diff --git a/perl/Makefile.PL b/perl/Makefile.PL
index 1df4f2c66..4ec6c1897 100644
--- a/perl/Makefile.PL
+++ b/perl/Makefile.PL
@@ -8,11 +8,11 @@ WriteMakefile(
'OBJECT' => 'rpm.o constant.o',
'VERSION_FROM' => 'rpm.pm', # finds $VERSION
'MAKEFILE'=> 'PMakefile',
- 'LIBS' => [' -L/usr/local/lib -R/usr/local/lib -L/usr/ucblib -R/usr/ucblib -lnsl -lsocket -ldb -lz -lbz2'], # e.g., '-lm'
+ 'LIBS' => [' -L/usr/local/lib -ldb1 -lz'], # e.g., '-lm'
'CCFLAGS' => '-g -O2 -D_GNU_SOURCE -Wall -Wpointer-arith -Wstrict-prototypes -Wmissing-prototypes -Wno-char-subscripts',
'OPTIMIZE'=> '-g',
'DEFINE' => '-Dbool=char -DHAS_BOOL',
- 'INC' => ' -I/usr/local/include -I$(top_builddir)/misc -I../build -I../lib -I../popt -I/usr/include/rpm',
+ 'INC' => ' -I../build -I../lib -I../popt -I/usr/include/rpm',
'depend' => { 'rpm.c' => 'transaction.xs header.xs db.xs' },
);