summaryrefslogtreecommitdiff
path: root/perl/Makefile.PL
diff options
context:
space:
mode:
authorjbj <devnull@localhost>2000-02-25 16:49:05 +0000
committerjbj <devnull@localhost>2000-02-25 16:49:05 +0000
commit9e75d5397f5a3d22d3ea884f0a859ddf8e2b13d7 (patch)
tree63ccf09090038297a9bba6a37499a50fcf5fe014 /perl/Makefile.PL
parent601d666d4825619b9ecd12b839efbe6b0ebe4516 (diff)
downloadrpm-9e75d5397f5a3d22d3ea884f0a859ddf8e2b13d7.tar.gz
rpm-9e75d5397f5a3d22d3ea884f0a859ddf8e2b13d7.tar.bz2
rpm-9e75d5397f5a3d22d3ea884f0a859ddf8e2b13d7.zip
- sparc-sun-solaris2.6 portability check.
CVS patchset: 3589 CVS date: 2000/02/25 16:49:05
Diffstat (limited to 'perl/Makefile.PL')
-rw-r--r--perl/Makefile.PL4
1 files changed, 2 insertions, 2 deletions
diff --git a/perl/Makefile.PL b/perl/Makefile.PL
index 02baf9f40..1df4f2c66 100644
--- a/perl/Makefile.PL
+++ b/perl/Makefile.PL
@@ -8,11 +8,11 @@ WriteMakefile(
'OBJECT' => 'rpm.o constant.o',
'VERSION_FROM' => 'rpm.pm', # finds $VERSION
'MAKEFILE'=> 'PMakefile',
- 'LIBS' => [' -L/usr/local/lib -ldb1 -lz -lbz2'], # e.g., '-lm'
+ 'LIBS' => [' -L/usr/local/lib -R/usr/local/lib -L/usr/ucblib -R/usr/ucblib -lnsl -lsocket -ldb -lz -lbz2'], # e.g., '-lm'
'CCFLAGS' => '-g -O2 -D_GNU_SOURCE -Wall -Wpointer-arith -Wstrict-prototypes -Wmissing-prototypes -Wno-char-subscripts',
'OPTIMIZE'=> '-g',
'DEFINE' => '-Dbool=char -DHAS_BOOL',
- 'INC' => ' -I../build -I../lib -I../popt -I/usr/include/rpm',
+ 'INC' => ' -I/usr/local/include -I$(top_builddir)/misc -I../build -I../lib -I../popt -I/usr/include/rpm',
'depend' => { 'rpm.c' => 'transaction.xs header.xs db.xs' },
);