summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsépius <corsepiu@fedoraproject.org>2007-09-03 10:17:40 +0200
committerRalf Corsépius <corsepiu@fedoraproject.org>2007-09-03 10:17:40 +0200
commitb977d7aa31f2104f17b8f4f52d824d6153471e0e (patch)
treefa98d44418b92e99c5e9a85e34c2778646ec2550 /lib/Makefile.am
parente27bbb931aae7457d1f02adddc6f4330db890845 (diff)
downloadrpm-b977d7aa31f2104f17b8f4f52d824d6153471e0e.tar.gz
rpm-b977d7aa31f2104f17b8f4f52d824d6153471e0e.tar.bz2
rpm-b977d7aa31f2104f17b8f4f52d824d6153471e0e.zip
Remove lint-support.
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am15
1 files changed, 1 insertions, 14 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index db9a51950..968ea4549 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -1,7 +1,5 @@
# Makefile for rpm library.
-LINT = splint
-
AM_CPPFLAGS = -I. \
-I$(top_srcdir) \
-I$(top_srcdir)/rpmdb \
@@ -72,18 +70,7 @@ getdate.c: getdate.y
fi ;\
fi
-BUILT_SOURCES = getdate.c # rpmlib.lcd
-
-rpmlib.lcd: Makefile.am ${librpm_la_SOURCES} ${pkginc_HEADERS}
- -lclint ${DEFS} ${AM_CPPFLAGS} ${librpm_la_SOURCES} -dump $@ 2>/dev/null
-
-.PHONY: sources
-sources:
- @echo $(librpm_la_SOURCES:%=lib/%)
-
-.PHONY: lint
-lint:
- $(LINT) $(DEFS) $(AM_CPPFLAGS) $(librpm_la_SOURCES)
+BUILT_SOURCES = getdate.c
if SELINUX
check_PROGRAMS += setfiles