summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPanu Matilainen <pmatilai@redhat.com>2008-04-28 13:53:35 +0300
committerPanu Matilainen <pmatilai@redhat.com>2008-04-28 14:02:51 +0300
commit48f19e86b56be0ae220ff1114711684dd04480bd (patch)
treee92d13ebc31bcd873dac423c078ab787eae110b9 /configure.ac
parentcf767c71c57491e3fb159762da9ae86ebb828ef0 (diff)
downloadrpm-48f19e86b56be0ae220ff1114711684dd04480bd.tar.gz
rpm-48f19e86b56be0ae220ff1114711684dd04480bd.tar.bz2
rpm-48f19e86b56be0ae220ff1114711684dd04480bd.zip
Require C99 capable compiler in configure
- also enable C99 mode if not on by default
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c683d6ccf..5de9cf7d3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -23,6 +23,11 @@ AC_PROG_MAKE_SET
AC_PROG_LIBTOOL
AC_PROG_YACC
+AC_PROG_CC_C99
+if test "$ac_cv_prog_cc_c99" = no; then
+ AC_MSG_ERROR([ISO C99 capable compiler required])
+fi
+
AS=${AS-as}
AC_SUBST(AS)
if test "$GCC" = yes; then