summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPanu Matilainen <pmatilai@redhat.com>2009-12-05 11:05:39 +0200
committerPanu Matilainen <pmatilai@redhat.com>2009-12-05 11:05:39 +0200
commit105518cf5766bba6647e26b96e31b5a2d8ba18c4 (patch)
treee2ae642f532877e0b47aeb9f363e448993c780cd /configure.ac
parent46d1ba04483af09590ed070186a1be10b57c5977 (diff)
downloadrpm-105518cf5766bba6647e26b96e31b5a2d8ba18c4.tar.gz
rpm-105518cf5766bba6647e26b96e31b5a2d8ba18c4.tar.bz2
rpm-105518cf5766bba6647e26b96e31b5a2d8ba18c4.zip
Bump up the python version requirement to match reality
- Python >= 2.6 is known to work, 2.5 might be possible with __future__ imports but until somebody tests it...
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 1 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index ad114b9cc..d071775e8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -670,9 +670,7 @@ esac],
[enable_python=no])
AS_IF([test "$enable_python" = yes],[
-# rpm-python is based on python-2.5,
-# with legacy hacks to allow building against python >= 2.3
- AM_PATH_PYTHON([2.3],[
+ AM_PATH_PYTHON([2.6],[
WITH_PYTHON_INCLUDE=`${PYTHON} -c 'from distutils.sysconfig import *; import sys; sys.stdout.write(get_python_inc())'`
WITH_PYTHON_SUBPACKAGE=1
save_CPPFLAGS="$CPPFLAGS"