summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsépius <corsepiu@fedoraproject.org>2007-09-13 14:51:46 +0200
committerRalf Corsépius <corsepiu@fedoraproject.org>2007-09-13 14:51:46 +0200
commitdf1b72d3af290d3d15d0501f2a116f685aee3c0c (patch)
tree6eff206abdcfee00195040c068fb4db8373b022b /Makefile.am
parenta019b8bf9670eb1d5b374defa646a32b47a0e097 (diff)
downloadrpm-df1b72d3af290d3d15d0501f2a116f685aee3c0c.tar.gz
rpm-df1b72d3af290d3d15d0501f2a116f685aee3c0c.tar.bz2
rpm-df1b72d3af290d3d15d0501f2a116f685aee3c0c.zip
Process platform in Makefile instead of configure.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index ceae46027..7c2803045 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -132,6 +132,14 @@ macros: $(top_srcdir)/macros.in
CLEANFILES += macros.tmp macros
EXTRA_DIST += macros.in
+platform: $(top_srcdir)/platform.in
+ @sed \
+ -e "s,[@]RPMCONFIGDIR[@],$(rpmconfigdir),g" \
+ < $(top_srcdir)/platform.in > platform.tmp \
+ && ( cd $(top_builddir) && ./config.status --file=${subdir}/platform:${subdir}/platform.tmp )
+CLEANFILES += platform.tmp platform
+EXTRA_DIST += platform.in
+
pkgsrcdir = $(prefix)/src/$(RPMCANONVENDOR)
pkgsrc_RPMSdir = $(pkgsrcdir)/RPMS
pkgsrc_RPMS_DATA =