summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPanu Matilainen <pmatilai@redhat.com>2008-11-21 16:13:03 +0200
committerPanu Matilainen <pmatilai@redhat.com>2008-11-21 17:59:33 +0200
commitddf59da4183f578cf1b7238892776bd64340282f (patch)
treee386f9e1fb070a71751855688f04da737def39de /Makefile.am
parent3a03a2fc4617efd8fb9f90d5279a10f0d4df1ef3 (diff)
downloadrpm-ddf59da4183f578cf1b7238892776bd64340282f.tar.gz
rpm-ddf59da4183f578cf1b7238892776bd64340282f.tar.bz2
rpm-ddf59da4183f578cf1b7238892776bd64340282f.zip
Kill the last remaining varprefix
- we're just mangling varprefix to localstatedir anyway, might as well just avoid that little extra trouble...
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 2 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index 74f103183..b509b6082 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -150,11 +150,8 @@ EXTRA_DIST += rpmrc.in
rpmconfig_DATA += macros
macros: $(top_srcdir)/macros.in
- @$(SED) \
- -e "s,[@]varprefix[@],$(localstatedir),g" \
- < $(top_srcdir)/macros.in > macros.tmp \
- && ( cd $(top_builddir) && ./config.status --file=${subdir}/macros:${subdir}/macros.tmp )
-CLEANFILES += macros.tmp macros
+ ( cd $(top_builddir) && ./config.status --file=${subdir}/macros:${subdir}/macros.in )
+CLEANFILES += macros
EXTRA_DIST += macros.in
noinst_DATA = platform