summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPanu Matilainen <pmatilai@redhat.com>2012-09-07 10:33:22 +0300
committerPanu Matilainen <pmatilai@redhat.com>2012-09-07 13:34:27 +0300
commit9e47043b2d23d6e6657a2a18dd325d2ef014dba3 (patch)
tree87e1dd44653e0c4840843d8657bd19146ed31097 /Makefile.am
parenta466227a2ff77c90f0b524792a5a1eda3e47cbe7 (diff)
downloadrpm-9e47043b2d23d6e6657a2a18dd325d2ef014dba3.tar.gz
rpm-9e47043b2d23d6e6657a2a18dd325d2ef014dba3.tar.bz2
rpm-9e47043b2d23d6e6657a2a18dd325d2ef014dba3.zip
First cut of a libsolv-style string <-> id pool API
- The pool stores "arbitrary" number of strings in a space-efficient manner, with near constant (hashed) string -> id lookup/store and constant time id -> string and id -> string length lookups. - Credits for the idea go to the Suse developers working on libsolv, the basic concept is directly lifted from there but details differ due to using rpm's own hash table implementation etc. Another minor difference is using size_t for offsets to permit over 4GB total data size on 64bit systems, the total number of id's in the pool is limited to uint32 max however (like in libsolv). - Any (re)implementation bugs by yours truly, this is almost certainly going to need further tuning and tweaking, API and otherwise.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 179c3e99c..9e170df99 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -58,6 +58,7 @@ pkginclude_HEADERS += rpmio/rpmlog.h
pkginclude_HEADERS += rpmio/rpmpgp.h
pkginclude_HEADERS += rpmio/rpmsq.h
pkginclude_HEADERS += rpmio/rpmstring.h
+pkginclude_HEADERS += rpmio/rpmstrpool.h
pkginclude_HEADERS += rpmio/rpmsw.h
pkginclude_HEADERS += rpmio/rpmfileutil.h
pkginclude_HEADERS += rpmio/rpmutil.h