summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsépius <corsepiu@fedoraproject.org>2007-10-16 18:21:27 +0200
committerRalf Corsépius <corsepiu@fedoraproject.org>2007-10-16 18:21:27 +0200
commit8ea05eb1dff52e93ea33433cc1efd274518ce167 (patch)
tree5d7e9d850e2cc55f9c49a6f87776c0778efae415 /Makefile.am
parent1a2234fe5429388b60e217b1608a6d5028a7d208 (diff)
downloadrpm-8ea05eb1dff52e93ea33433cc1efd274518ce167.tar.gz
rpm-8ea05eb1dff52e93ea33433cc1efd274518ce167.tar.bz2
rpm-8ea05eb1dff52e93ea33433cc1efd274518ce167.zip
Use \$(SED) instead of hard-coded sed.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 6 insertions, 6 deletions
diff --git a/Makefile.am b/Makefile.am
index 8810691d3..1b32f37dd 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -64,7 +64,7 @@ pkginclude_HEADERS += build/rpmfc.h
pkginclude_HEADERS += build/rpmspec.h
-rpmbindir = `echo $(bindir) | sed -e s,usr/bin,bin,`
+rpmbindir = `echo $(bindir) | $(SED) -e s,usr/bin,bin,`
rpmbin_PROGRAMS = rpm
bin_PROGRAMS = rpm2cpio
@@ -154,7 +154,7 @@ rpmsort_LDADD = lib/librpm.la
rpmconfig_DATA = rpmrc
rpmrc: $(top_srcdir)/rpmrc.in
- @sed \
+ @$(SED) \
-e "s,[@]SYSCONFIGDIR[@],$(sysconfdir)/rpm,g" \
< $(top_srcdir)/rpmrc.in > rpmrc.tmp \
&& ( cd $(top_builddir) && ./config.status --file=${subdir}/rpmrc:${subdir}/rpmrc.tmp )
@@ -163,7 +163,7 @@ EXTRA_DIST += rpmrc.in
rpmconfig_DATA += macros
macros: $(top_srcdir)/macros.in
- @sed \
+ @$(SED) \
-e "s,[@]varprefix[@],$(localstatedir),g" \
< $(top_srcdir)/macros.in > macros.tmp \
&& ( cd $(top_builddir) && ./config.status --file=${subdir}/macros:${subdir}/macros.tmp )
@@ -172,7 +172,7 @@ EXTRA_DIST += macros.in
noinst_DATA = platform
platform: $(top_srcdir)/platform.in
- @sed \
+ @$(SED) \
-e "s,[@]RPMCONFIGDIR[@],$(rpmconfigdir),g" \
< $(top_srcdir)/platform.in > platform.tmp \
&& ( cd $(top_builddir) && ./config.status --file=${subdir}/platform:${subdir}/platform.tmp )
@@ -181,7 +181,7 @@ EXTRA_DIST += platform.in
pkgconfig_DATA = rpm.pc
rpm.pc: $(top_srcdir)/rpm.pc.in
- @sed \
+ @$(SED) \
-e "s,[@]RPMCONFIGDIR[@],$(rpmconfigdir),g" \
< $(top_srcdir)/rpm.pc.in > rpm.pc.tmp \
&& ( cd $(top_builddir) && ./config.status --file=${subdir}/rpm.pc:${subdir}/rpm.pc.tmp )
@@ -190,7 +190,7 @@ EXTRA_DIST += rpm.pc.in
rpmconfig_DATA += rpmpopt-$(VERSION)
rpmpopt-@VERSION@: $(top_srcdir)/rpmpopt.in
- @sed \
+ @$(SED) \
-e "s,[@]RPMCONFIGDIR[@],$(rpmconfigdir),g" \
< $(top_srcdir)/rpmpopt.in > rpmpopt-@VERSION@.tmp \
&& ( cd $(top_builddir) && ./config.status --file=${subdir}/rpmpopt-@VERSION@:${subdir}/rpmpopt-@VERSION@.tmp )