summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPanu Matilainen <pmatilai@redhat.com>2010-03-23 16:21:27 +0200
committerPanu Matilainen <pmatilai@redhat.com>2010-03-23 16:32:46 +0200
commit8c7e53ec80e84f48bfc67181f3d5dd81ecdb7523 (patch)
tree1777f57f13aaa83b3e1c77ba66f2d8e29547e8e1 /Makefile.am
parent7628c31bb9688c04561bd46c840ec9437fab4f67 (diff)
downloadrpm-8c7e53ec80e84f48bfc67181f3d5dd81ecdb7523.tar.gz
rpm-8c7e53ec80e84f48bfc67181f3d5dd81ecdb7523.tar.bz2
rpm-8c7e53ec80e84f48bfc67181f3d5dd81ecdb7523.zip
First take at pluggable file attribute + dependency extraction system
- move most of the hardwired classification logic from rpmfc C-code to macro-based configuration, supporting drop-in addition of arbitrary new attributes + dependency extractors based on regex matching of libmagic file types and paths - just the initial rough conversion of our built-in dependency types, various open questions + todo-items remain, plus likely fair amount of more-or-less subtle breakage
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 1000648ff..6cd0bdd8d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -19,9 +19,9 @@ endif
if WITH_LUAEXT
SUBDIRS += luaext
endif
-SUBDIRS += rpmio lib build python scripts doc . tests
+SUBDIRS += rpmio lib build python scripts fileattrs doc . tests
-DIST_SUBDIRS = po misc luaext rpmio lib build python scripts doc tests
+DIST_SUBDIRS = po misc luaext rpmio lib build python scripts fileattrs doc tests
pkgconfigdir = $(libdir)/pkgconfig