summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPanu Matilainen <pmatilai@redhat.com>2010-10-01 10:34:36 +0300
committerPanu Matilainen <pmatilai@redhat.com>2010-10-01 10:34:36 +0300
commit8b4ccff2e36876dcfbdba9f38f4ec9dcdef2166e (patch)
tree9daac42bbbb7df8982413d35202419c8629dad44 /Makefile.am
parent6059911eb827152e22a8f3bb061147734a0ab283 (diff)
downloadrpm-8b4ccff2e36876dcfbdba9f38f4ec9dcdef2166e.tar.gz
rpm-8b4ccff2e36876dcfbdba9f38f4ec9dcdef2166e.tar.bz2
rpm-8b4ccff2e36876dcfbdba9f38f4ec9dcdef2166e.zip
Handle enable/disable python to configure.ac more sanely
- Conditionalize the python subdir on toplevel make instead of python subdir makefile.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index ece4a7188..456d239c8 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -19,7 +19,11 @@ endif
if WITH_LUAEXT
SUBDIRS += luaext
endif
-SUBDIRS += rpmio lib build python scripts fileattrs doc . tests plugins
+SUBDIRS += rpmio lib build scripts fileattrs doc . tests plugins
+
+if ENABLE_PYTHON
+SUBDIRS += python
+endif
DIST_SUBDIRS = po misc luaext rpmio lib build python scripts fileattrs doc tests plugins