summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPanu Matilainen <pmatilai@redhat.com>2011-11-09 15:04:13 +0200
committerPanu Matilainen <pmatilai@redhat.com>2011-11-09 15:16:28 +0200
commit70f063cb773bedb7d336429d9bc8ed1d4e5d18f4 (patch)
tree6d525fdbb1e92051dda4b05e5c23fc7f2e531f71 /Makefile.am
parent6bced5bc08c3c8291fc7488c35e1703cba0f9ef6 (diff)
downloadrpm-70f063cb773bedb7d336429d9bc8ed1d4e5d18f4.tar.gz
rpm-70f063cb773bedb7d336429d9bc8ed1d4e5d18f4.tar.bz2
rpm-70f063cb773bedb7d336429d9bc8ed1d4e5d18f4.zip
Make base64 encoding/decoding part of rpmio public API
- Base64 is present in headers and all, it's only reasonable that our API users have access to this functionality without having to link to other libraries. Even if we didn't want to carry the implementation forever in our codebase, we should provide a wrapping for this (much like the other crypto stuff) for the reason stated above. - A bigger issue is that our dirty little (badly hidden) secret was using non-namespaced function names, clashing with at least beecrypt. And we couldn't have made these internal-only symbols even on platforms that support it, because they are used all over the place outside rpmio. So... rename the b64 functions to rpmLikeNamingStyle and make 'em public. No functional changes, just trivial renaming despite touching numerous places.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index b1568a6d1..179c3e99c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -62,6 +62,7 @@ pkginclude_HEADERS += rpmio/rpmsw.h
pkginclude_HEADERS += rpmio/rpmfileutil.h
pkginclude_HEADERS += rpmio/rpmutil.h
pkginclude_HEADERS += rpmio/rpmkeyring.h
+pkginclude_HEADERS += rpmio/rpmbase64.h
pkginclude_HEADERS += lib/header.h
pkginclude_HEADERS += lib/rpmdb.h