summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPanu Matilainen <pmatilai@redhat.com>2010-09-29 12:01:49 +0300
committerPanu Matilainen <pmatilai@redhat.com>2010-09-29 12:12:58 +0300
commit6d04be21eb6384bb56472fc774d9d6c4ba00b438 (patch)
tree66ebe64f8bdd287d3388b4294b5b325cf87d830f /Makefile.am
parent23a9d64ea40cfb526d0a12ba7350918dc335a305 (diff)
downloadrpm-6d04be21eb6384bb56472fc774d9d6c4ba00b438.tar.gz
rpm-6d04be21eb6384bb56472fc774d9d6c4ba00b438.tar.bz2
rpm-6d04be21eb6384bb56472fc774d9d6c4ba00b438.zip
And finally split the signing support into a separate library
- For a library with just one public function this might seem like a huge overkill but it permits cleanly separating dependencies: nothing but package signing requires GnuPG. This lets the signing support be stuffed into a separate package, avoiding having to drag gpg in on every installation (signing isn't something everybody does) and without having potentially broken interfaces in the API, essentially solving RhBug:624585. It also liberates signing to use libraries that might be off-limits for the core rpm, such as perhaps in the future doing signing by ourselves with the help of something like gpgme (which requires far too many things to drag into core rpm).
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 4102e6aec..ece4a7188 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -70,6 +70,8 @@ pkginclude_HEADERS += lib/rpmtypes.h
pkginclude_HEADERS += lib/rpmvf.h
pkginclude_HEADERS += lib/rpmplugins.h
+pkginclude_HEADERS += lib/rpmsign.h
+
pkginclude_HEADERS += build/rpmbuild.h
pkginclude_HEADERS += build/rpmfc.h
pkginclude_HEADERS += build/rpmspec.h
@@ -113,7 +115,7 @@ rpmkeys_LDADD += @WITH_NSS_LIB@ @WITH_POPT_LIB@ @WITH_ZLIB_LIB@
rpmsign_SOURCES = rpmsign.c debug.h system.h
rpmsign_CPPFLAGS = $(AM_CPPFLAGS)
rpmsign_LDADD = libcliutils.la
-rpmsign_LDADD += lib/librpm.la rpmio/librpmio.la
+rpmsign_LDADD += lib/librpmsign.la lib/librpm.la rpmio/librpmio.la
rpmsign_LDADD += @WITH_NSS_LIB@ @WITH_POPT_LIB@ @WITH_ZLIB_LIB@
rpmbuild_SOURCES = rpmbuild.c debug.h system.h