summaryrefslogtreecommitdiff
path: root/src/tests/Makefile.am
diff options
context:
space:
mode:
authorAnas Nashif <anas.nashif@intel.com>2012-11-22 06:35:44 -0800
committerAnas Nashif <anas.nashif@intel.com>2012-11-22 06:35:44 -0800
commitf51c187432a2b2a5845142e6b662e81303b2ea94 (patch)
tree780a77f4566bcd40699807df516fa1e562e77886 /src/tests/Makefile.am
downloadremix-upstream.tar.gz
remix-upstream.tar.bz2
remix-upstream.zip
Imported Upstream version 0.2.4upstream/0.2.4upstream
Diffstat (limited to 'src/tests/Makefile.am')
-rw-r--r--src/tests/Makefile.am24
1 files changed, 24 insertions, 0 deletions
diff --git a/src/tests/Makefile.am b/src/tests/Makefile.am
new file mode 100644
index 0000000..30c817a
--- /dev/null
+++ b/src/tests/Makefile.am
@@ -0,0 +1,24 @@
+## Process this file with automake to produce Makefile.in
+
+AM_CFLAGS = -Wall -pedantic
+
+INCLUDES = -I$(top_srcdir)/include -I$(top_srcdir)/src/ctxdata
+
+REMIX_LIBS = ../ctxdata/libctxdata.la ../libremix/libremix.la -ldl
+
+# Test programs
+
+TESTS_ENVIRONMENT = $(VALGRIND_ENVIRONMENT)
+
+test: check
+
+TESTS = noop sndfiletest
+
+noinst_PROGRAMS = $(TESTS)
+noinst_HEADERS = tests.h
+
+noop_SOURCES = noop.c
+noop_LDADD = $(REMIX_LIBS)
+
+sndfiletest_SOURCES = sndfiletest.c
+sndfiletest_LDADD = $(REMIX_LIBS) @SNDFILE_LIBS@