summaryrefslogtreecommitdiff
path: root/packaging/re2c.spec
diff options
context:
space:
mode:
authorTizenOpenSource <tizenopensrc@samsung.com>2024-01-22 15:17:09 +0900
committerTizenOpenSource <tizenopensrc@samsung.com>2024-01-22 15:17:09 +0900
commitd7601c7d28b74c0c89532e18368eb867d6508402 (patch)
treedb3c60c3422abdb59e4dba9910acb5feab75c2b8 /packaging/re2c.spec
parentd6ea7e7c4172902086eab521ac7e74fab2009efd (diff)
downloadre2c-d7601c7d28b74c0c89532e18368eb867d6508402.tar.gz
re2c-d7601c7d28b74c0c89532e18368eb867d6508402.tar.bz2
re2c-d7601c7d28b74c0c89532e18368eb867d6508402.zip
Signed-off-by: TizenOpenSource <tizenopensrc@samsung.com>
Diffstat (limited to 'packaging/re2c.spec')
-rw-r--r--packaging/re2c.spec48
1 files changed, 48 insertions, 0 deletions
diff --git a/packaging/re2c.spec b/packaging/re2c.spec
new file mode 100644
index 00000000..dd4e9165
--- /dev/null
+++ b/packaging/re2c.spec
@@ -0,0 +1,48 @@
+Name: re2c
+Version: 3.1
+Release: 0
+License: PD
+Summary: Tool for generating C-based recognizers from regular expressions
+Url: http://re2c.org/
+Group: Development/Libraries/C and C++
+Source: %{name}-%{version}.tar.bz2
+Source1001: re2c.manifest
+
+BuildRequires: gcc-c++
+BuildRequires: pkgconfig(python3)
+
+%description
+re2c is a tool for writing fast and flexible lexers. Unlike other such
+tools, it concentrates solely on generating efficient code for matching
+regular expressions. This makes it suitable for a wide variety of
+applications. The generated scanners approach hand-crafted ones in
+terms of size and speed.
+
+%prep
+%setup -q
+cp %{SOURCE1001} .
+find -type d -name .svn -print0 | xargs -r0 rm -rf
+find CHANGELOG lessons examples -type f -print0 \
+ | xargs -r0 chmod -v a-x
+
+%build
+export CFLAGS+=" -fPIC"
+export CXXFLAGS+=" -fPIC"
+export LDFLAGS+=" -pie"
+mkdir -p m4
+autoreconf -i -W all
+
+%configure
+%{__make} %{?_smp_mflags}
+
+%install
+%make_install
+%remove_docs
+
+%files
+%manifest %{name}.manifest
+%defattr(-,root,root,-)
+%{_bindir}/re2c
+%{_bindir}/re2go
+%{_bindir}/re2rust
+%{_datadir}/re2c/stdlib/unicode_categories.re