diff options
author | gchanan <gregchanan@gmail.com> | 2018-02-27 14:51:11 -0500 |
---|---|---|
committer | GitHub <noreply@github.com> | 2018-02-27 14:51:11 -0500 |
commit | d5038309a150d028ffa445ed5e05d07ca5e59e0b (patch) | |
tree | 0ade2295b739924a0f4ff5d4b7c28c73129725a3 /setup.py | |
parent | 8327982904d7b2ffb2096314ba9de02ce495b806 (diff) | |
download | pytorch-d5038309a150d028ffa445ed5e05d07ca5e59e0b.tar.gz pytorch-d5038309a150d028ffa445ed5e05d07ca5e59e0b.tar.bz2 pytorch-d5038309a150d028ffa445ed5e05d07ca5e59e0b.zip |
Remove WITH_SCALARS, as it's enabled by default now. (#5437)
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 10 |
1 files changed, 0 insertions, 10 deletions
@@ -40,9 +40,6 @@ # WITH_GLOO_IBVERBS # toggle features related to distributed support # -# WITH_SCALARS -# build with native support for scalars (zero-dim tensors) -# # PYTORCH_BINARY_BUILD # toggle static linking against libstdc++, used when we're building # binaries for distribution @@ -115,10 +112,6 @@ IS_WINDOWS = (platform.system() == 'Windows') IS_DARWIN = (platform.system() == 'Darwin') IS_LINUX = (platform.system() == 'Linux') -if 'WITH_SCALARS' not in os.environ: - os.environ['WITH_SCALARS'] = '1' -WITH_SCALARS = check_env_flag('WITH_SCALARS') - NUM_JOBS = multiprocessing.cpu_count() max_jobs = os.getenv("MAX_JOBS") if max_jobs is not None: @@ -723,9 +716,6 @@ if DEBUG: extra_compile_args += ['-O0', '-g'] extra_link_args += ['-O0', '-g'] -if WITH_SCALARS: - extra_compile_args += ['-DWITH_SCALARS'] - if os.getenv('PYTORCH_BINARY_BUILD') and platform.system() == 'Linux': print('PYTORCH_BINARY_BUILD found. Static linking libstdc++ on Linux') # get path of libstdc++ and link manually. |