diff options
author | Peter Goldsborough <peter@goldsborough.me> | 2018-03-13 16:23:02 -0700 |
---|---|---|
committer | Soumith Chintala <soumith@gmail.com> | 2018-03-13 19:23:02 -0400 |
commit | bab0f8484b4ec4444ae12cb7b0bb2d62dbc4c9a8 (patch) | |
tree | d1c102ebac1f990ef1247912981e694d1dd5a8a5 /setup.py | |
parent | 16fa12214d061d020753c2fb0861b03a304027f7 (diff) | |
download | pytorch-bab0f8484b4ec4444ae12cb7b0bb2d62dbc4c9a8.tar.gz pytorch-bab0f8484b4ec4444ae12cb7b0bb2d62dbc4c9a8.tar.bz2 pytorch-bab0f8484b4ec4444ae12cb7b0bb2d62dbc4c9a8.zip |
Put torch header install back into the install command (#5755)
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 12 |
1 files changed, 6 insertions, 6 deletions
@@ -395,12 +395,6 @@ class build_ext(build_ext_parent): else: print('-- Building without distributed package') - # Copy headers necessary to compile C++ extensions. - self.copy_tree('torch/csrc', 'torch/lib/include/torch/csrc/') - self.copy_tree('torch/lib/pybind11/include/pybind11/', - 'torch/lib/include/pybind11') - self.copy_file('torch/torch.h', 'torch/lib/include/torch/torch.h') - generate_code(ninja_global) if WITH_NINJA: @@ -424,6 +418,12 @@ class install(setuptools.command.install.install): if not self.skip_build: self.run_command('build_deps') + # Copy headers necessary to compile C++ extensions. + self.copy_tree('torch/csrc', 'torch/lib/include/torch/csrc/') + self.copy_tree('torch/lib/pybind11/include/pybind11/', + 'torch/lib/include/pybind11') + self.copy_file('torch/torch.h', 'torch/lib/include/torch/torch.h') + setuptools.command.install.install.run(self) |